Both are in CF11 (https://wikidocs.adobe.com/wiki/display/coldfusionen/QueryGetRow); neither are in Lucee 4.5
Should be implemented for the sake of cross-compat.
This is FYI only, and is not impacting me at all. So no urgency to do anything.
this is the same as "queryRowData", we have chosen this name because it is consistent with the existing function "QueryColumnData", we should add this only as alias to this function, i dont want to have 2 functions in our portfolio that are doing the same, problem we are not supporting alias for function names yet, we only do for argument names.
I added this function but marked as deprecated, as soon we implement ticket LDEV-147, we will remove the declaration of this function again and only set as an alias with "queryRowData"
Um, if it's just an alias, you're perhaps better off just leaving it as-is (including marking it as deprecated). There is no overhead for you that way, is there? And you maintain sideways compat at the same time.