Details

    • Type: Bug
    • Status: Deployed
    • Priority: New
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.5.5.005, 5.1.1.63
    • Labels:
      None
    • Sprint:
      February 2017 Release

      Description

      Diagnosis
      The error updating from Java 6 to a version using Java 7 or higher.
      Cause
      Wildcard / multi-domain SSL certificates, when Java has SNI enabled and an Apache proxy is in place.
      Exception message:

      javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
      

      Workaround
      Disable SNI for Java by adding the -Djsse.enableSNIExtension=false environment variable to the

      for more details see:
      https://issues.apache.org/jira/browse/HTTPCLIENT-1522

        Attachments

          Activity

            People

            • Assignee:
              michaeloffner Michael Offner
              Reporter:
              michaeloffner Michael Offner
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: