Failed update generates java.util.zip.ZipException after restarting Tomcat/Lucee

Description

I attempted to update my install of 5.3.5.92 today. During the update, there was some kind of error that occurred that resulted in the tomcat/lucee-server/patches/5.3.6.61.lco being a 0-byte file.

Once that happened, any attempt to access any Lucee-related resource resulted in a java.util.zip.ZipException being thrown.

To resolve the issue, I had to delete the invalid tomcat/lucee-server/patches/5.3.6.61.lco file.

This thread seems to show the same kind of issue:

https://dev.lucee.org/t/java-util-zip-zipexception-error-in-opening-zip-file/7269

It would seem like any invalid file in the tomcat/lucee-server/patches/ folder should be ignored and/or removed.

Environment

None

Activity

Show:
Pothys - MitrahSoft
August 25, 2020, 10:57 AM

I've checked this ticket and confirmed the issue happened on only with lucee - 5.3.5.92.
And also tested with some versions, but have not seen this issue with that versions.
, will confirm about this.

Arowolo Abiodun
September 7, 2020, 2:43 PM

Just had

Just had a similar issue…

Zac Spitzer
September 7, 2020, 2:58 PM

please always mention which version(s) of lucee are affected

Arowolo Abiodun
September 7, 2020, 3:33 PM

Can't remember the version (its 5.3.xx)
This happened by chance. Lucee was already running, so I spine up another instance using terminal (../startup.sh) and this error came up.

Could not get around the error

Assignee

Michael Offner

Reporter

Dan Switzer, II

Priority

New

Labels

Fix versions

None

Affects versions

Configure