Upgrade Hibernate Extension to Latest version (5)

Description

Lucee's current Hibernate extension is on Hibernate 3.5 which came out in 2010. We've completely missed Hibernate 4 and now Hibernate 5 is out. Adobe ColdFusion 2018.0.0 is shipping with Hibernate 5.2.11-SNAPSHOT. Update the Lucee Hibernate extension to a current and SUPPORTED version.

Activity

Show:
Jamie Jackson
October 8, 2018, 1:46 PM

Aside from the general best practice of using supported/modern libraries (which is a valid reason unto itself), are there any known/suspected benefits in the ultimate functionality of cform from upgrading Hibernate?

Assignee

Unassigned

Reporter

Brad Wood

Priority

Critical
Configure