javaProxy() (and webserviceProxy()) poorly named
Description
Environment
Activity
Adam Cameron 18 April 2015 at 20:25
Yes. This is why I suggested there needs to be more openness about how this is done. There was a thread about this on the Google Group (wrong place, right idea), but then it seemed Micha decided he'd read enough about it and just picked a solution and did it. Rather than waiting for a group consensus (ohhohohohoh, like that would happen, which is why I suggested it was the wrong place), and then arriving at one, then implementing THAT.
No code changes should have been done on this ticket yet. So now it should be reopened, and revisited. TBH, if it was on one of our projects @ work, the code would be backed-out and the develop would be ballocked. But we're not quite there yet with the way dev decisions are made on this project. Which reminds me... [goes back to Lucee Google Group...]
Andrew Dixon 18 April 2015 at 19:15
I'm more than happy to go with whatever the prevailing opinion is on this but as it's just me and you at the moment there isn't one, we just need one more person
Adam Cameron 18 April 2015 at 18:02
Well, @andrewdixon : we can agree to disagree in the case of the web service object then. Your point does hold up with Java objects though.
Oh, and hey... if the function was `createWebserviceObject()` it's not as if I'd be complaining it should be called `createWebserviceProxy()`. I just do see the case for using proxy in this case. But not the Java case. It's wrong in the Java case.
Andrew Dixon 18 April 2015 at 17:45
From the Google Group:
Andrew:
Emm, this is used to connect to SOAP (Simple Object Access Protocol) web services, so I'm sorry it doesn't return a proxy it returns an object, the give away is in the second word of the name of the protocol!!!
Adam:
It's a protocol to connect to (remote) objects. On the CFML end you have a proxy for that object. You're not calling methods on the remote object directly - one would need to do that via an HTTP call, or natively on the remote computer - you're calling methods on the proxy which then translates that into an HTTP request (and a bunch of other tedious crap), and sends it, and handles the response converting it back into CFML. So it's... err... a proxy for the actual object.
--------------------------------------------
Well, what you get if you dump the return is a object with a list of method, properties, etc... so while I know exactly what you are saying, to me the underlying "bunch of other tedious crap" it has to do is unimportant to me, I just get the "object" and do stuff to that and it takes care of the rest, so to me it's an object, as all I do is call the method of the "object" it has returned in the same way I would do with a component or Java one.
Not that soap services tend to be all that reliable and should be avoided if at all possible IMHO!!!
Aside: BitBucket your comment markdown is very sadly lacking!!!
Adam Cameron 18 April 2015 at 17:32
Andrew as I said on the forums, I agree "proxy" is wrong to be included in the Java version of these functions, but it does make sense in the case of the web service one.
Micha, did the community come to a conclusion regarding these names before you changed them, or did you make a unilateral decision here? I thought this was still under discussion?
Details
Assignee
UnassignedUnassignedReporter
Adam CameronAdam CameronPriority
MajorFix versions
New Issue warning screen
Before you create a new Issue, please post to the mailing list first https://dev.lucee.org
Once the issue has been verified, one of the Lucee team will ask you to file an issue
Affects versions
Details
Details
Assignee
Reporter
Priority
Fix versions
New Issue warning screen
Before you create a new Issue, please post to the mailing list first https://dev.lucee.org
Once the issue has been verified, one of the Lucee team will ask you to file an issue
Extracted from "Lucee 5 beta: the PHPification of CFML":
(same applies to webserviceProx(), natch)