Rename this.xmlFeatures to this.xmlSettings for consistency in application.cfc

Description

Can we change the new this.xmlFeatures settings to this.xmlSettings? This will keep the setting names consistent:

  • this.ormSettings = {};

  • this.javaSettings = {};

  • this.xmlSettings = {};

See original naming discussion here:

https://luceeserver.atlassian.net/browse/LDEV-1676

Igal Sapir - May 14, 2019 at 3:13 PM

@Pete Freitag Does ACF implement a feature like this? If so, we should try to use the same syntax and naming.

Pete Freitag - May 14, 2019 at 3:43 PM

I suggested xmlFeatures as a name because the java API has setFeature(), but this.xmlConfig sounds good to me as well.
… ACF has not implemented this yet…

... (later)

Pete Freitag - August 26, 2019 at 3:16 PM
...
I think my original though of having the settings closely tied to the java implementation was not a good idea because the java implementation naming is a confusing mess.

Activity

Show:

Details

Assignee

Reporter

Labels

New Issue warning screen

Before you create a new Issue, please post to the mailing list first https://dev.lucee.org

Once the issue has been verified, one of the Lucee team will ask you to file an issue

Affects versions

Priority

Created 2 September 2022 at 17:47
Updated 14 September 2022 at 08:12

Flag notifications