Searching/Filtering Not Installed Application Extensions Error

Description

Launched server via Command Box using the following command server start cfengine=lucee@5.0.0+252

Then navigated to the server/web admins and secured them with a password. I then clicked on the link that went to /lucee/admin/server.cfm?action=ext.applications and did a search on the Not Installed Applications section to filter.

This resulted in the following error:

Subsequent visits to that section of the admin result in the above error straight away. Logging out and back into the admin allows the section to load again, but filtering again results in that section immediately throwing the above error.

Not sure where it's getting this path, but that's definitely not where the application is located.

Environment

Windows 7 started server via Commandbox 3.2

Activity

Show:
William Giles
September 7, 2016, 11:02 PM

Also having this issue on Linux (centOS / ubuntu - 64bit) 5.0.0+252 && 5.0.0+254

Michael Offner
September 19, 2016, 8:47 AM

any comment on this?

Brad Wood
September 19, 2016, 6:22 PM

I remember reproducing it back when came across it. As far as I know, it's a bug in Lucee. If you're thinking perhaps it's related to using CommandBox, I just confirmed the bug exists in Lucee Express, so it appears unrelated to CommandBox.

As far as the path, "/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.", ignore that-- it's just the path that the .cfm file was at when it was compiled (on Micha's machine). Since it's bytecode now, it doesn't really have a new path, just a reference to the path it was compiled from.

Pothys - MitrahSoft
August 13, 2020, 4:02 PM

I hope this issue was fixed. So I close this ticket.

Fixed

Assignee

Michael Offner

Reporter

Tim Brown

Priority

Minor

Labels

None

Fix versions

None

Affects versions

Configure